Jump to content
Mesd

CAESES in Ansys Workbench issue

Recommended Posts

Hello, I'm trying to do a duct shape optimization by coupling a CAESES parametric model with the ANSYS ICEM and CFX components.

For that, I generate a simple parametric duct in CAESES and export the .fsc file, but when I try to import it in the CAESES ACT Extension and click update, I get the following error (see attached image).

However, the ANSYS Geometry tile in the CAESES module is ticked, despite not having a geometry when I open it (second image).

Any help on what may cause this problem would be appreciated.

 

r.png

r1.png

Share this post


Link to post
Share on other sites

Hey,

have you checked if your desired geometry is imported correctly in DesignModeler? It is important that your part name has the correct ending. For example if you export a sat-file, name it "whole_part.sat" as shown in the screenshot below. Furthermore, give it a try without an underscore in the name.

del.png.af59f571e6bcaf401dc37313e8901d2d.png

 

Best wishes

Bastian

Share this post


Link to post
Share on other sites

Hi, thanks for your response. In workbench I only import the .fsc file. And the name is "duct.fsc", I don't know where the name "whole_part" comes from.

It there a chance it might be a directory issue? Should the workbench directory be in the same one as the CAESES? But I've I tried this option and the error keeps popping up.

In the image from workbench below, it seems that Design Modeler fails to read a valid CAD model. Should I export a .iges, .stp or another CAD file with the .fsc file as well? Or is just the .fsc file enough, and the CAESES module does the rest.

Thanks again.

workbench.png

Share this post


Link to post
Share on other sites

Hi,

the CAESES-file and the workbench do not have to be in the same directory. To check if the DesignModeler receives a geometry, just open it. By updating the CAESES module in the workbench, the FSC-File opens CAESES, exports the geometry and so on. You do not have to deal with other exports than your FSC-file.

My screenshot above originates from CAESES. Please check the folder you want to export, its content and the names as shown in the screenshot.

 

In case you did not read it so far, CAESES provides a perfect and detailed manual how to achieve your objective:del.thumb.png.097f911e555224e1348cd3a25c35cd1e.png

 

Best wishes

Bastian

Share this post


Link to post
Share on other sites

Ok, so I tried reinstalling the extension and now this error stop showing and everything loads normal. But when I open Design Modeler, the imported geometry has an error (image 1) and the error is the one in image 2.

Again, thanks a lot for your time.

dm.png

dm2.png

Share this post


Link to post
Share on other sites

I assume the first part of the error message "Error: No compatible interface found for this file type" refers to the exported file type. 

Please try different file types like .stl, .step, .sat and so on 

Share this post


Link to post
Share on other sites

If I try to manually import the CAD file as a .sat for example, it gets imported but then it won't update if I change a CAESES variable in the parameter panel, which is why I'm using CAESES in the first place.

Share this post


Link to post
Share on other sites

Please ensure your export folder has the correct setting as shown in my first screenshot from monday.

Furthermore, you could have a closer look what is exported by Caeses when updating a parameter in this file path:

207635138_Screenshot2021-04-08080017.png.4e668b3fd120862e01abd81348c734ea.png

  • Like 1

Share this post


Link to post
Share on other sites

Ok first of all thanks a lot for your responses. What I was doing wrong, is that I wasn't exporting the whole project script, and I was trying to export just a specific scope script, so obviously this produced the aforementioned errors. Also, a valid CAD format must be exported as well.

Anyway thanks again for helping me.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...