Jump to content
mlysyshyn

OpenFOAM connection error

Recommended Posts

Hello,

I am really new to CAESES and I tried the s-duct tutorial, followed all steps but I am getting an message: 

External process start failure [Starting process C:/Users/HP/Desktop/skola/DP/sduct/sduct/manual_results/baseline/Runner//Allrun failed: Process failed to start:]

Currently using OpenFOAM v1912 installed on Ubuntu 18.04 for Windows 10, Allrun and stdouterroroutput files are attached.

I will really appreciate any help! 

 

stdouterroroutput.redirect Allrun

Share this post


Link to post
Share on other sites

Hi Mlysyshyn,

I can see that the files are are moved to their related locations.

Can you please share any console output?

Or some OpenFoam logs where the problem can be tracked?

Cheers

Ceyhan

  • Upvote 1

Share this post


Link to post
Share on other sites

Hello Ceyhan,

I managed to run optimization for sduct once, but now I am trying to do it once more and literally nothing happens when I start the runner. What is interesting, if I open minnty.exe manually It already has those lines inside:

OpenFOAM for Windows 19.10 (v1)
bash: dirname: command not found
bash: cygpath: command not found
bash: sed: command not found
bash: cygpath: command not found
bash: //OpenFOAM-dev/etc/config.sh/functions: No such file or directory
bash: //OpenFOAM-dev/bin/foamEtcFile: No such file or directory
bash: _foamSource: command not found
bash: _foamEval: command not found
bash: //OpenFOAM-dev/bin/foamCleanPath: No such file or directory
bash: //OpenFOAM-dev/bin/foamCleanPath: No such file or directory
bash: //OpenFOAM-dev/bin/foamCleanPath: No such file or directory
bash: _foamSource: command not found
bash: _foamSource: command not found
bash: cygpath: command not found
bash: //OpenFOAM-dev/bin/foamEtcFile: No such file or directory
bash: _foamSource: command not found
bash: //OpenFOAM-dev/bin/foamEtcFile: No such file or directory
bash: _foamSource: command not found
bash: //OpenFOAM-dev/bin/foamEtcFile: No such file or directory
bash: _foamSource: command not found
bash: //OpenFOAM-dev/bin/foamEtcFile: No such file or directory
bash: _foamSource: command not found
bash: //OpenFOAM-dev/bin/foamEtcFile: No such file or directory
bash: _foamSource: command not found
bash: //OpenFOAM-dev/bin/foamCleanPath: No such file or directory
bash: //OpenFOAM-dev/bin/foamCleanPath: No such file or directory
bash: //OpenFOAM-dev/bin/foamCleanPath: No such file or directory
bash: //OpenFOAM-dev/etc/config.sh/functions: No such file or directory
bash: mkdir: command not found
bash: cygpath: command not found
bash: cd: C:/Users/HP/Desktop/skola/DP/sduct3/Sduct_with_openfoam_2_FSYS/manual_results/baseline/OpenFOAM/: No such file or directory
bash: Allrun.sh: command not found
bash: tee: command not found

I am not an expert in Linux, nor Openfoam, so probably there is one more stupid mistake, which I cannot figure out by myself. Thanks in advance!

Share this post


Link to post
Share on other sites

Hi Mlysyshyn,

Can you please share your project file if it is not confidential?

You can also send it to erdem@friendship-systems.com

so that I can give a look at your SoftwareConnector setup.

Cheers

Ceyhan

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi Mlysyshyn,

Please find attached the modified version.

Some modifications I have performed;

1) Within the Runner for the "Local Application" I have selected the AllRun.bat which I have created. Please note that I am not using any arguments.

screen1.thumb.png.0d03aa294ef69beedcd42ac790eafcdc.png

2) The RunAll.bat executable includes commands within the "C:\OpenFOAM\19.10\cygwin64\Cygwin.bat" executable (lines 4-9) and the path to my script file which is the AllRun.sh (line 9)

 

screen2.thumb.png.8b8c1e5f644864293a21641a63101ab4.png

 

3) Finally made a little modification to the script file.

screen3.thumb.png.917bfa9eab7d3e78075ccdc0af657487.png

 

The final configuration seems to be working but didn't pay attention to the OpenFoam setup.

Cheers

Ceyhan

Sduct_with_openfoam_2_FSYS.fdbc

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi Ceyhan,

Thank you for your time, I really appreciate that! 

I have tried new configurations, but it still does not work. I am attaching the output file. Any chance there is something wrong with my OpenFOAM or Cygwin?

And also is it better to use another .bat file to call the bash application than setting minnty.exe as executable directly like it was shown during one of the webinars?

Thanks in advance.

 

stdouterroroutput.redirect

Share this post


Link to post
Share on other sites

Hi Mlysyshyn,

For sure you can do that as well.

Will create the new configuration and send it once I have some time today.

Cheers

Ceyhan

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi Mlysyshyn,

I am waiting for some feedback from the CFDSupport guys.

Meanwhile I would suggest you to use the solution that I have provided you earlier.

Cheers

Ceyhan

Share this post


Link to post
Share on other sites

bump same issue my ./Allrun does not work meanwhile OF4WIN does work. I can run manually the configuration and then I can run the STL with linux commands. As soon as I attempt to use the ./Allrun script it will not run any of the commands and I have attempted to simplify my commands even to just blockMesh and it will not find the commands. The terminal from CAESES outputs that top response because it is not finding any of the commands from the dictionary.

Weird because ./Allrun script shouldn't be causing these issues unless there is a weird communication or specific structure

Share this post


Link to post
Share on other sites

So update I followed several of the Ahmed, Sduct and propeller OpenFOAM for Windows setups. I've downloaded simFlow engine for Openfoam for windows and found the .bat file actually runs fine on my desktop through terminal/command prompt however when I allow CAESES to execute the file it fails to find any of the commands stated such as blockMesh etc. So is this an administrator rights issue or something else that I can edit to fix? I literally copied over the Sduct simflow workflow demo and if I execute the Allrun.bat or manually execute each command via command prompt outside of CAESES everything works fine. Only when CAESES is told to run the .bat I receive issues with unrecognized commands for the dictionary etc. So Im unsure why through the software connector its unable to execute properly. I also relinked all the files to the folder.

Moving C:/Users/Christian/Desktop/simflow/manual_results/baseline/Runner/input/0 to C:/Users/Christian/Desktop/simflow/manual_results/baseline/Runner//0

Moving C:/Users/Christian/Desktop/simflow/manual_results/baseline/Runner/input/allrun.bat to C:/Users/Christian/Desktop/simflow/manual_results/baseline/Runner//allrun.bat

Moving C:/Users/Christian/Desktop/simflow/manual_results/baseline/Runner/input/constant to C:/Users/Christian/Desktop/simflow/manual_results/baseline/Runner//constant

Moving C:/Users/Christian/Desktop/simflow/manual_results/baseline/Runner/input/system to C:/Users/Christian/Desktop/simflow/manual_results/baseline/Runner//system

[Captured output from application C:/Users/Christian/Desktop/simflow/manual_results/baseline/Runner//allrun.bat]

C:\Users\Christian\Desktop\simflow\manual_results\baseline\Runner>surfaceFeatureExtract

'surfaceFeatureExtract' is not recognized as an internal or external command,

operable program or batch file.

C:\Users\Christian\Desktop\simflow\manual_results\baseline\Runner>blockMesh

'blockMesh' is not recognized as an internal or external command,

operable program or batch file.

C:\Users\Christian\Desktop\simflow\manual_results\baseline\Runner>snappyHexMesh -overwrite

'snappyHexMesh' is not recognized as an internal or external command,

operable program or batch file

Share this post


Link to post
Share on other sites
On 7/30/2020 at 1:20 AM, Mr. Christian Anzalotta said:

The solution was to run both the simflow installer and CAESES installer with admin rights and run them with admin rights. No issues now!

Hi Christian,

I am not sure if I understtod right, I only need to reinstall Caeses and openfoam and when reinstalling run both installers with admin rights, yes?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...