Jump to content
Mr. Matheus Wolff Machado

Enabling multicore loads with CAESES

Recommended Posts

Title, is it possible? I'm noticing changing design variables only hits a single core, which leads to waits of up to 15 seconds while re-rendering the surface with a modern (2019) system. I've noticed the "number or processes" option in settings but it doesn't seemingly change performance(even though i make sure not to increase it above my six-core capabilities). Thanks in advance.

EDIT: There was an error within my parameters which slowed the re-rendering a lot, it's back to being almost instantaneous. Still, the question about multi-core workloads remain, as i'm just in the tutorials and imagine more complex structures might benefit from it.

Share this post


Link to post
Share on other sites

Dear Matheus,

you are absolutely right. Indeed, complex models can benefit a lot from parallel computing. Unfortunately, up to the latest CAESES 4.x no such option is available (except for the settings referring to multiple external tools running in parallel during an optimization that you mentioned). However, one of the mayor changes of our upcoming release CAESES 5, is in fact the full parallelization. If you are particularly interested in this feature you can stay tuned via our newsletter here: https://www.caeses.com/news/newsletter/

P.S: Often times it makes sense to take a closer look at what particular part of your geometry slows down the update -- you can use the profiler (go to help > start profiling, then trigger a model refresh, i.e. by changing a design variable and then go to help > stop profiling) to get statistics of the most time consuming objects in your model.

Cheers,

Heinrich

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, Mr. Heinrich von Zadow said:

Dear Matheus,

-

Cheers,

Heinrich

Thanks a lot! That's great to know CAESES never stops improving :)
Regarding questions about tutorials, should i just post them here in Miscellaneous or do you have any better-suited alternatives? I'm struggling with the screenshot collection, it never shows up at the design viewer even though the preview looks fine.

image.png

screenshot collection.PNG

Share this post


Link to post
Share on other sites
1 hour ago, Mr. Heinrich von Zadow said:

Dear Matheus,

I guess it's fine to post them in the misc area.

Regarding the Design Viewer: have you checked that you are looking at the right results table (see Screenshot)?

 

Cheers,

Heinrich

There's only this one option or a blank page, behaviour does not change whether i make screenshots during Sobol or afterwards.Fresh project, only clicks were Open Sample > Optimization > select parameters > new screenshot method > Selecting 3DView > Preview works > 5 iterations > Run.image.thumb.png.b973e8df4b0ea221c7f162ba38120d2e.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...