Jump to content

Mr. Konrad Lorentz

  • Content Count

  • Joined

  • Last visited

Posts posted by Mr. Konrad Lorentz

  1. did you modified your CAESES-FFW.sh or did your opened a terminal, changed the working directory to /opt/CAESES-FFW_3.0.10_Linux.x86_64 (or somewhere),



    export LD_LIBRARY_PATH=lib/Linux.x86_64/

    gdb bin/Linux.x86_64/CAESES-FFW


    wait for the prompt and entered "run"


    got the crash and the the gdb wrote be itself "quit" ? (instead of "run")



  2. Hi,


    yes, actually this can be the problem. Please make sure to install a HAL demon (see http://en.wikipedia.org/wiki/HAL_%28software%29). If I am not mistaken udev should be fine, too, but we have to wait for our Linux expert as Claus said.




    Please try again with version 3.0.9.

    Could you maybe add some more details about "it starts running"? What's the last thing you see?

    Also, please post the startup logfile if the problem persists (see the following post for details on how to locate it: http://www.friendship-systems.com/forum/index.php?/topic/28-how-do-i-handle-error-messages-when-starting-the-framework-or-caeses/ ).

    HAL is not the problem! Do not install the libhal ...

  3. You could ask a Linux expert in your neighborhood, search in forums or read the manual of how to use gdb.


    Without the backtrace I'm not able to help you, sorry. Otherwise try to start it on a gnome-session.


    Are you sitting in front of the workstation, or remotely?


    Did you really installed a 3D driver, what is the output of (on the first page you said you had it)

    glxinfo | grep rend



  4. Hi James,


    It seems to be a problem of OpenFOAM variable resolving!


    Maybe you didn't setup your OpenFOAM environment before starting CAESES-FFW.


    To do that:

    - you can modify the CAESES-FFW.sh start script and add the following lines in the header (not in the first line, you need the shebang!)

    - you can modify your  ~/.bashrc to have the environment settings in all your Terminals(note: you have to run the CAESES-FFW out of a terminal).

    - you can  modify your  ~/.profile to have the environment settings for all your applications (even from the Desktop Icon, if you created one)

    (-> please read for more details or find a man page for your distribution)

    export FOAM_INST_DIR=/data/app/OpenFOAM
    [ -f $foamDotFile ] && . $foamDotFile

    With that setup you will always "source" (load) the required OpenFOAM environment before starting CAESES-FFW.


    Otherwise the line in the script "Allrun" would not be succesful.

    . $WM_PROJECT_DIR/bin/tools/RunFunctions

    more installation help could be found here:





  5. Hi Richard, please do not cross-post in this forum. Your issue was resolved via IssueTracker.


    Hi Stephane.


    You don't need HAL! Don't invest time in it! Your OS is using UDISKS2, which we support too, to get the same information we need



    Please post the startuplog! .friendship/etc/logs/startuplog.html


    please install GDB (zypper install gdb)


    start the CAESES-FFW as follows:

      cd /tmp/
      cd CAESES-FFW_3.0.9_Linux.x86_64
      export LD_LIBRARY_PATH=lib/Linux.x86_64/
      echo run | gdb bin/Linux.x86_64/CAESES-FFW

    if you get the segfault: enter "bt" and press ENTER.



    Please send me the output.





  6. Dear James,


    An installation like a windows installation is not necessary. Simply download the tar.bz2. Extract it and run it. If it is running the first time, you need to register your installation in case of a commercial use or you need to create a CAESES access. Everything is managed with the same start binary.




    # open a Terminal
    # goto your favorite folder
    cd /opt
    # download CAESES-FFW
    wget http://www.friendship-systems.com/downloads/software/software-archive/CAESES-FFW_3.0.9_Linux.x86_64.tar.bz2
    # extract the container
    tar xf CAESES-FFW_3.0.9_Linux.x86_64.tar.bz2
    # start the application




  • Create New...