
Integrations                                 

Coupling CAESES® and ANSYS® CFX®: S-Duct Example 

The purpose of this tutorial is to learn the integration of a 3rd party CFD software, in this case 

ANSYS® ICEM CFD™ and ANSYS® CFX®. You will use existing s-duct geometry, prepare it for the 

export and connect it with ANSYS®. 

For the meshing setup we will use 

ANSYS® ICEM CFD™. While the simulation 

setup and the run will be performed with 

ANSYS® CFX® and for the post processing  

ANSYS® CFD-Post is utilized. 

 

 

The s-duct geometry is created and linked 

to the software connector interface in CAESES®. Scripts for automating and controlling the 

whole process are created and then linked to the CAESES® software connector with the help of 

parameters. Finally, the simulation is executed, and the results are collected by CAESES® for 

post processing and optimization. 

For any further questions you can use the CAESES® forum. 

  

http://www.caeses.com/forum
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1 
Open the S-Duct Model 

The model from which we will start can be found in the documentation 

browser: 

► Open the project samples > design engines > s-duct geometry variation. 

► Save it as a new project. 

 

Here is a very brief overview of this model, before we continue with the ANSYS® CFX®. 

integration: 

The first step of modeling the s-duct is to define the shape of the 

cross section. This is done inside the feature by using a NURBS 

curve with different transformations. The position of the cross 

section depends on the path. This feature definition will be the 

input for the curve engine. From the curve engine, a meta 

surface gets finally created, which sweeps the cross section 

along the path. 

Different functions define the parameters of the cross section along the path, which are 

additional inputs for the curve engine. The functions are usually smooth B-Spline curves, where 

the x-position defines the curve path’s parameter position (0 to 1) and the y-position the value 

of the parameter. These y-values can be controlled by design variables. You can move the points 

of the functions in y-direction, to see how the model changes. 
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2 
Prepare Geometry for Export: Lids 

In order to export the geometry as a watertight CFD domain, we have to 

close the inlet and outlet and create a brep. 

► Go to menu and select CAD > surfaces > more (Coons Patch) > lid for a closed surface edge. 

► Rename the feature to “outletsurface”. 

► Select the circular edge of the duct surface as the source for C1. 

► Click “Create”. It is also possible to create the feature first, and then select the input curve. 

► Repeat this step for the inlet surface naming it “inletsurface”. 
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3 
Prepare Geometry for Export: BRep 

Now we can create a brep from the geometry components. 

 

► Create a brep via CAD > breps > brep and call it “sduct_export”. 

► Under the operations menu, choose add sources and choose “duct”. 

 

► Click on the “Create Custom Color” button and expand it. 

► Choose the desired color and press “Create New Color” by renaming it, “wall”. 

► Enable the operation. 

► Finally perform the previous four steps within the same brep both for “inlet” and “outlet” 

and naming the colors “inlet” and “outlet” respectively. 
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4 
Import the Software Connector 

Now we can import a prepared software connector which includes the 

ANSYS® ICEM CFD™, ANSYS® CFD-Post and ANSYS® CFX® files. It was 

configured before (for the purpose of this tutorial). The software connector is the widget where 

external tools can be plugged-in. 

► Go to the connections tab in the pull down menu and choose “Software Connector From 

File”. 

► Select the file “06_ANSYS_Integration_softwareconnector.xffl” that you will find in the 

installation directory > tutorials > 08_integrations. 
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5 
Software Connector: Input Geometry 

Now we can begin to set up the input geometry in the software 

connector. 

► Drag and drop the brep “sduct_export” into the Input Geometry window of the connector. 

► Click on this file, and specify the file name to “Sduct.tin”. 

► Set the export type to “Tetin”. 

 

  

The export file format Tetin (*.tin) for ANSYS ICEM CFD. With this export, the unique CAESES® 

IDs of edges and faces are directly transferred to ICEM CFD, and the user can rely on them when 

setting up a meshing process. 
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6 
Software Connector: Set up Coupling  

In this step, we will configure the software connector to trigger 

automatic simulation execution using these files. 

► Open cfxrun.sh in the software connector. 

► Highlight the “ANSYSDIR” in line 5. 

► Create a new entry by right-clicking on 

the highlighted “ANSYSDIR” and select 

“New Entry”. 

► Click the name of the entry to edit its 

properties. 

► Change the type to fstring, and rename it to “AnsysDir”. 

► Change the text in the field to your local ANSYS directory. 

► Highlight “RESULTPATH” in line 6 and create a new entry. 

► Rename it to “Resultpath” and change the type to fstring.  

► Type getResultsDir() in the entry field, which returns the result directory for the current 

design.  
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11 7 
Parameterize the Input File Sduct.rpl 

In this step we will edit the Sduct.rpl meshing input file by creating 

controls for mesh parameters. 

 

► Find the working directory (“RESULTPATH“) and replace all with the “ResultsPath” entry. 

► Find the ANSYS directory (“ANSYSDIR“) and replace all with the “AnsysDir” entry. 

 

► Search “Sduct.rpl” for the part size parameters, “ic_geo_set_family_params ” (line 47) and 

create new entries for the boundary layer parameters on the surface “WALL” by moving 

the cursor over the appropriate numerical values and clicking the dialogue that appears. Do 

this for element height, ehght and number of layers, nlay (line 47 and 55). 

► Finally check the file to make sure that paths leading to files exported by CAESES® are 

replaced by the ResultsPath entry, and that the filenames themselves are replaced by 

entries for any exported files. 
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12 8 
Parameterize the Input File Sduct.pre 

In this step we will edit the ANSYS® CFX® input file, Sduct.pre by creating 

controls for imported and exported files. 

 

► Open Sduct.pre  

► Find the working directory (“RESULTPATH“) and replace all with the “ResultsPath” entry. 
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12 
Parameterize the Input File Sduct.ccl 

In this step we will edit the ANSYS® CFX® case file, Sduct.ccl by creating 

controls for boundary conditions. 

 

► Open Sduct.ccl and search for the INLET and OUTLET boundaries. 

► Create entries for inlet normal velocity and outlet relative pressure conditions. Do this for 

other simulation parameters, which you might think would be useful, such as number of 

iterations, convergence criteria, and timescale factor. 

 

  

Once the simulation is started, it can be monitored manually using the CFX solve manager, 

alternatively, CFX can be configured to automatically monitor each run, or export the convergence 

history to CSV files which can be read by CAESES as results tables for each run. 
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9 
Parameterize the Input File Sduct.cse 

In this step we will edit the ANSYS® CFD-Post post process input file, 

Sduct.cse by creating controls. 

 

► Open Sduct.cse  

► Find the working directory (“RESULTPATH“) and replace all with the “ResultsPath” entry. 
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10 
Setting up the Computation 

For postprocessing, we need to have results files and values, which will 

be inserted in the Results Files and Results Values window of the software 

connector. In order to get these, we have to trigger a first run – either with CAESES®, or 

externally. Since we have already changed parts of the input files in the previous steps, we want 

to use CAESES® to run ANSYS® CFX®. Therefore we have to set up the computation “Runner”: 

► Click on “Runner” in the center of the software connector. 

► In the object editor of the selected object “Runner”, activate 

“Remove existing Result Files”. This makes sure that with 

each run the previous simulation files get deleted 

automatically, and is similar to the 

“Allclean” command. 

► Create a new “Local Application” by 

clicking on the plus-button next to the 

attribute, and call it “CFXRUN”. 

► As executable write “cfxrun.sh”. This will 

trigger the “cfxrun.sh” script. 

► Run the computation by clicking on the 

green run button (). 

► While the computation is running, you 

can check the output in the Task Monitor.  

When the computation is done, check the 

results on your hard disc, to see how the 

results are handled by CAESES®: A new folder 

was created, with the name of the current 

project file (*.fdb). In this folder all results can 

be found.  
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11 
Result Values Part 1 

In order to assess the simulation, we need to have result files which 

provide for example the pressure drop. These values can be extracted 

from any text files. 

► In your file explorer, go to the baseline directory which was created during the last run and 

check for the “values.txt” file. 

► Add the “values.txt” file to the Results Values window of the software connector by using 

either drag & drop, or by using the green plus button at the window. 

► Double-click on “values.txt” in the software connector to see the content. 
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12 

 Remember that this parameter is the result value of the last iteration or time step. If you have 

a strong oscillating result, you might average the values over a specific time. 

Result Values Part 2 

After importing the template result file. We are now able to extract result 

values such as the pressure drop. 

► Add a value by clicking on the plus button and name it “dP”. 

► In Anchor String part add “Table 5.” where CAESES® will be searching from this point on. 

► Set line to “1” (in this case, this means: always the last row of the file). 

► Set column to “0”. 

► Now create a parameter for the value by clicking on the blue parameter symbol in the 

results preview table. This parameter will be the objective of the simulation at a later stage. 

► Select the evaluation parameters, and create a scope. Set the name of this scope to 

“CFX_evaluation” (note, names can be user-defined i.e. arbitrary). 
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13 
Result Files 

In the Result Files window of the connector, output files from the CFD 

calculation are referenced. Typical output files are pictures, tables, text 

files and CFD solutions. 

► Add the “Sduct.res.case” Ensight file to this window, either by using drag & drop, or by 

using the plus button in the corner. 
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14 
Running the Case 

Now the software connection is completed, and a first test case can be 

started. 

► Set the parameter 

 Maximum_Number_of_Iterations to “1000”. 

► You can also decrease the “Residual_Target” 

factor, which will increase the computational 

time. 

► Go back to the software connector and run the 

simulation (again by using the  button). 
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Appendix 

This appendix will guide you through the process of creating your own ANSYS script files. 
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A1 
Meshing with ANSYS® ICEM CFD® Part 1 

In this section, a script file is created using ANSYS® ICEM CFD® to 

automate basic unstructured meshing of the flow domain.  

► Open ANSYS® ICEM CFD®. 

► Begin recording scripts by selecting “File > Replay Scripts > Replay Control”. Ensure that 

recording scripts is checked 

 

 

 

 

 

 

 

 

 

 

► Change the working directory of ICEM to the working directory by selecting “File > Change 

Working Dir…” 

► Import the geometry file by following the path “File > Geometry > Open Geometry” and 

selecting Sduct.tin as the import file.  
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A2 
Meshing with ANSYS® ICEM CFD® Part 2 

In this step we are going to continue to create the meshing macro. 

 

► Under Geometry tab, pick Repair Geometry and click OK in the 

opening menu. 

► Under the mesh tab, bring up the part mesh-setup dialogue, 

and input size parameters for all surfaces imported using the 

values indicated. Leave all other parameters as zero. 

 

 

 

 

 

 

 

 

► Create an unstructured volume 

mesh by bringing up the Compute 

Mesh dialogue box under the 

Volume Mesh tab. 

► Create a boundary layer under 

the Prism Mesh tab. 

When the mesh is finished, inspect the 

prism mesh and split the elements if 

desired. 
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A3 
Meshing with ANSYS® ICEM CFD® Part 3 

In this step we are going to continue to create the meshing macro. 

 

► Click through the “Settings > Solver menu” to bring up the solver setup dialogue and 

specify ANSYS® CFX® as the solver type. 

► Click on the output tab and select write input to write the mesh files, save the project when 

prompted to the working directory. 

► Ensure that the .boco file is also saved in the working directory, and then export the files. 

► In the replay control window, select “Done” and save the replay in the working directory as 

“Sduct.rpl”. 

► Close ANSYS® ICEM CFD®. 

 

 

 

 

 

 

 

 

 

 

 

  

Group parts by giving them identical spacing, which later you can easily find by searching for 

the spacing value and link to a common entry in the software connector 
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A4 
Set up the CFX Case file Part 1 

In this step we will create a template simulation setup and a script file  

using CFXpre to automatically generate a simulation setup and export 

the solver definition file. 

► Open CFX and create a new project, importing the mesh generated in the previous section. 

► Set up the simulation case as desired or as is necessary. Some basic sample boundary 

conditions are: 

Boundary Name Boundary Type Details 
inlet Inlet  Normal velocity: 1.0 m/s 

outlet Outlet Zero average gauge pressure 
wall Wall No slip - Rotating 

 

► Ensure to set up an execution control object, this will be important for defining the solver 

working directory. 

► Export the case setup from the menu by 

browsing through File > Export > CCL, naming 

the file “Sduct.ccl”, and ensuring to select “save 

all objects” to export the entire setup. 

► Close the project 
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A5 
Set up the CFX Case file Part 2 

Follow up of the step before. 

 

► Create a new session file, naming it Sduct.pre and save it to the working directory, then 

select “Start Recording”. 

 

 

 

 

 

 

► Import the mesh file Sduct.cfx5. 

► Import the Sduct.ccl file created. 

► Write a solver input file to the working directory. 

► Stop recording and close CFX, saving the project if desired. 
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A6 
Set up Basic Post Processing and Results Part 1 

Finally, a script file is created to automate post processing in CFX Post, 

and integrated into CAESES to automate the post processor execution.  

Results are imported into CAESES for post processing and optimization. 

► Open CFXpost and start a new session, saving it to the working directory, and naming the 

script file “Sduct.cse”.  

► Start the recording. 

► Create a table in CFX post to compute the pressure difference between the inlet and outlet 

boundaries, and then export it as a txt file in the working directory. 

► Create a new table in the report section of the CFX Post object tree by right-clicking on 

report heading, and selecting “Insert > Table”. 

 

► In the first cell, enter the following equation: 

“=massFlowAve(Total Pressure)@inlet -massFlowAve(Total Pressure)@outlet”. 
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A7 
Set up Basic Post Processing and Results Part 2 

Follow up of the post processing and results set up. 

 

► Uncheck all items in the report subheading except the table created in the previous step, 

then right click on report and select publish. 

► Select “Text” as the Export format, and then export the file to the working directory. 

► Stop recording. 
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