BCAESES

Coupling CAESES® and ANSYS® CFX®: S-Duct Example

The purpose of this tutorial is to learn the integration of a 3rd party CFD software, in this case
ANSYS® ICEM CFD™ and ANSYS® CFX®. You will use existing s-duct geometry, prepare it for the

export and connect it with ANSYS®.

For the meshing setup we will use
ANSYS® [CEM CFD". While the simulation
setup and the run will be performed with
ANSYS® CFX® and for the post processing
ANSYS® CFD-Post is utilized.

The s-duct geometry is created and linked

to the software connector interface in CAESES®. Scripts for automating and controlling the
whole process are created and then linked to the CAESES® software connector with the help of
parameters. Finally, the simulation is executed, and the results are collected by CAESES® for

post processing and optimization.

For any further questions you can use the CAESES® forum.
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http://www.caeses.com/forum

B CAESES

Open the S-Duct Model

The model from which we will start can be found in the documentation

browser:

»  Open the project samples > design engines > s-duct geometry variation.

» Saveitasanew project.

Here is a very brief overview of this model, before we continue with the ANSYS® CFX®.

integration:

The first step of modeling the s-duct is to define the shape of the -
cross section. This is done inside the feature by using a NURBS /
curve with different transformations. The position of the cross {

section depends on the path. This feature definition will be the |
input for the curve engine. From the curve engine, a meta | |
surface gets finally created, which sweeps the cross section \ /
along the path. \h, //

Different functions define the parameters of the cross section along the path, which are
additional inputs for the curve engine. The functions are usually smooth B-Spline curves, where
the x-position defines the curve path’s parameter position (0 to 1) and the y-position the value
of the parameter. These y-values can be controlled by design variables. You can move the points

of the functions in y-direction, to see how the model changes.
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Prepare Geometry for Export: Lids

In order to export the geometry as a watertight CFD domain, we have to

close the inlet and outlet and create a brep.

Rename the feature to “outletsurface”.

Select the circular edge of the duct surface as the source for C1.

vVvyyvyyvyy

Repeat this step for the inlet surface naming it “inletsurface”.

o E' - Z Documentation Browser X (RISl
]

2\

@ B-Splne Surface
@ NURBS Surface

D2

More 4

@ Ruled Surface
« @ Lofted Surface
@ @ surface of Revolution

9] @ coons Patch

More > =
Lid for a closed surface edge
( Image Surface Lid for a closed surface edge

@ Meta Surface

B CAESES

Go to menu and select CAD > surfaces > more (Coons Patch) > lid for a closed surface edge.

Click “Create”. It is also possible to create the feature first, and then select the input curve.

More >
@ Sub Surface
More 4 Splts the edge curve in 4
parts and creates a coons
G Filet Surface patch as a lid.
Create Feature: lid -0
Description
@ outlet o
Spits the edge curve in 4 parts and crestes a coons patch as a
lid.
02 surface duct:edged - IE]
Display Options
e 7@
m Preview [ Create o Cancel
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Prepare Geometry for Export: BRep

Now we can create a brep from the geometry components.

v

Create a brep via CAD > breps > brep and call it “sduct_export”.

»  Under the operations menu, choose add sources and choose “duct”.

vVvyyy

mg Ennnectlons|b Opt\mlzat\on| @ B = 4 » |sduct_export L0 x
Type - Name Quick Find (Ctrl+F)
4 [JB baseline @ | sduct_export ‘ 4
FScope 3 - 00_functions
FScope » [0 01_path General
FScope 4 - 02_surface Global Tol 7
FCurveEngine engine oos TokrEnee | ‘ |[D
FMetaSurface + G duct s |Check\.’a\idrry O [3|
FBrep - @ sdur:tiexpnrt\ |
FFeature::id < @ inletsurface Transformation | H[@
FFeature::ld + (@ outletsurface .
4 Feature Definitions ITERGIS
Q x |‘ add sources " A
Sources
+ 0 +‘0275urface|du::t '|
t O+ @
| Drop here to append ‘
Click on the “Create Custom Color” button < and expand it.
Choose the desired color and press “Create New Color” by renaming it, “wall”.
Enable the operation.
Finally perform the previous four steps within the same brep both for “inlet” and “outlet”
. s » “ » :
and naming the colors “inlet” and “outlet” respectively. A A bl L0 x
O]
@ | sduct_export | 4 [wall |
o wall
General 7 General
Global Tolerance | [-](2) a Blue |10t E@
Check Validity (] @ Geen[2ss  [*{(3)
. FTR—l
Transformation | |'|[B Red (9 (2
Operations
Basic colors
© X ® add sources - a ® 11101
Sources EEEIECTE
= EEEEECEE
v °+‘02_5urface|duct - EEEEEEE
A -
rO+ @ ...
| Drop here to append EEEEEEENE
Splt: at ‘Tangent Magnitude Discontinuity (C1) '| [B
B Custom colors Hue: 112 Red: 119 %/
Color ‘ wal '| P @ OoOO0O0000 - -ﬂ
Green
Surface Extension o 0oooooo D B\ue
[ Add to Custom Colors
H- add new operation v| \Create New Color| = Cancel |
T




Import the Software Connector

B CAESES

Now we can import a prepared software connector which includes the

ANSYS® ICEM CFD™, ANSYS® CFD-Post and ANSYS® CFX® files. It was

configured before (for the purpose of this tutorial). The software connector is the widget where

external tools can be plugged-in.

>

installation directory > tutorials > 08_integrations.

Sl 1= 0™  chcomecor |

HAO SRR Sduct.pre X | Sduct.rpl X | cfxrun.sh X |Sduct.cd X | Sduct.cse X

+(

+00

Input Geometry

Result Files

Q Runner

cfxrun.sh

Go to the connections tab in the pull down menu and choose “Software Connector From
File”.

Select the file “06_ANSYS_Integration_softwareconnector.xffl” that you will find in the

Input Files @ Q +

]
MATERIAL GRE

Sduct.cdl Sduct.cse

Result Values @ +
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Software Connector: Input Geometry

Now we can begin to set up the input geometry in the software

connector.

» Dragand drop the brep “sduct_export” into the Input Geometry window of the connector.
»  Click on this file, and specify the file name to “Sduct.tin”.
»  Setthe export type to “Tetin”.

AE4r Qo= ® - bR ERCETEN

e —— - ] 28 Overview [ |Sduct.rp| x |cfxrun.
Source |M| ° gl —
rerame [saom | |
ExportType Tetn |-/ | @
Entry Value [Relative Path |- |(2]
4+ © < sduct_export - d
O+ ]| =
| Drop here to append | g

‘/ The export file format Tetin (*.tin) for ANSYS ICEM CFD. With this export, the unique CAESES®
IDs of edges and faces are directly transferred to ICEM CFD, and the user can rely on them when

setting up a meshing process.



vy

v

vVvyyvyyvyy

B CAESES

Software Connector: Set up Coupling

In this step, we will configure the software connector to trigger

automatic simulation execution using these files.

|- Overview| Sduct.pre X |Sduct.rpl X

& Template Name | cfxrun.sh

Open cfxrun.sh in the software connector.

Highlight the “ANSYSDIR” in line 5.

Create a new entry by right-clicking on : 5
1 #!/bin/sh
the highlighted “ANSYSDIR” and select 2 i # source the bash
ERN ~/.bashrec
“New Entry”. 4
S i # BNS
Click the name of the entry to edit its s # mES
properties. 8 echo " Entries

Change the type to fstring, and rename it to “AnsysDir”.
Change the text in the field to your local ANSYS directory.
Highlight “RESULTPATH” in line 6 and create a new entry.
Rename it to “Resultpath” and change the type to fstring.

Type getResultsDir() in the entry field, which returns the result directory for the current
design.

RE4APD L0 x LR QA x

(€| config (€)| config

General General

config config

AnsysDir |"fopt/ansys_inc/v162" - :’: AnsysDir "Jopt/ansys_inc/v162" @ :7:

- — =
ResultsPath - 2J
getResultsDir() e -

b3 N Q x » 4N Q x

Entry e e 3k ~) Entry 1+ @

& |AnsysDir &5 ResultsPath

General e General °

Type FString = -2 Type FString - (@)
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Parameterize the Input File Sduct.rpl

In this step we will edit the Sduct.rpl meshing input file by creating

controls for mesh parameters.

» Find the working directory (“RESULTPATH") and replace all with the “ResultsPath” entry.
» Find the ANSYS directory (“ANSYSDIR") and replace all with the “AnsysDir” entry.

|- Overview Sduct.pre X cfxrun.sh X | Sduct.cc X |Sduct.cse X

& Template Name | Sduct.rpl

28
29
30
31
3z
33
34
35
36
37
a8

Eic_run_tetra Sduct.tin RESUTTBATH/tat+ra mesh wna vnn enttear 1 delete_auto 1
iic_geo_set modified 1

{ic_uns_update_family_ type v New Entry ET CRFN} {!NODE
iic boco solver -

L= - . Entries »
iic_uns_update family type v Exports 4
ic_boco_clear_ icons )
‘ic_csystem display all 0 AnsysDir
iic_csystem set current glob _
ic_boco_nastran_csystem res: ResuftsPath
‘ic_uns_diagnostic diag_type

E:?_c_smooth_elements map all 1 Cut Ctrl+x s !} n_proce;so

»  Search “Sduct.rpl” for the part size parameters, “ic_geo_set family_params ” (line 47) and

create new entries for the boundary layer parameters on the surface “WALL” by moving

the cursor over the appropriate numerical values and clicking the dialogue that appears. Do

this for element height, ehght and number of layers, nlay (line 47 and 55).

»  Finally check the file to make sure that paths leading to files exported by CAESES® are

replaced by the ResultsPath entry, and that the filenames themselves are replaced by

entries for any exported files.
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Parameterize the Input File Sduct.pre

In this step we will edit the ANSYS® CFX® input file, Sduct.pre by creating

controls for imported and exported files.

» Open Sduct.pre

»  Find the working directory (“RESULTPATH") and replace all with the “ResultsPath” entry.

Overview |cfxrun.sh X | Sduct.rpl % Sduct.ccl X |values.txt X Sduct_001.out X |Sduct.cse X
# Template Name  Sduct.pre

B A R

@

# Session file stopped: 2016/03/09% 13:58:57

4 Session file started: 2016/03/09 13:59:06
# Build 16.2 2015.06.30-00.03-134402

COMMAND FILE:
CFX Pre Version = 16.2
END

>load mode=new
> update

> gtmImport filename=<entry>ResultsPath</entry>\

Sduct.cfx5, type=Generic, units=m, genOpt= -n, nameStrategy= Assembly

> update

>importccl filename=<entry>Exports|sduct.ccl</entry>, mode = replace, autoLoadLibrary = none

> update

>WriteCaseFile filename=<entry>ResultsPath</entry>\
Sduct.def, operation=write def file

> update

> update

4 Session file stopped: 2016/03/09 14:00:13
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Parameterize the Input File Sduct.ccl

In this step we will edit the ANSYS® CFX® case file, Sduct.ccl by creating

controls for boundary conditions.

»  Open Sduct.ccl and search for the INLET and OUTLET boundaries.
» Create entries for inlet normal velocity and outlet relative pressure conditions. Do this for
other simulation parameters, which you might think would be useful, such as number of

iterations, convergence criteria, and timescale factor.

Overview | cfxrun.sh X | Sduct.pre X |Sduct.rpl X [Ef(iladsl Sduct.cse X

# Template Name | Sduct.cdl

491 MASS AND MOMENTUM: &
492 Normal Speed = <entry>Speed</entry> [m s*-1]

453 Cption = Normal Speed

494 END

495 TURBULENCE :

496 Option = Medium Intensity and Eddy Viscosity Ratio
497 END

498 END

499 END

500 BOUNDARY: outlet

301 Boundary Type = OUTLET

502 Location = QUTLET

503 BCUNDARY CCNDITIONS:

504 FLOW REGIME:

505 Option = Subsonic

Soe END

507 MASS AND MOMENTUM:

508 COption = Average Static Pressure

509 Pressure Profile Blend = 0.05

510 Relative Pressure = <entry>Pressure</entry> [Pa]
511 END

595 CONVERGENCE CONTRCL: &
5596 Length Scale Option = Conservative

597 Maximum Number of Iterations = <entry>Iterations</entry>
598 Minimum Number of Iterations = 1

539 Timescale Control = Auto Timescale

600 Timescale Factor = 1.0

601 END

602 CCNVERGENCE CRITERIA:

603 Residual Target = <entry>Target</entry>

604 Residual Type = RMS

\/Once the simulation is started, it can be monitored manually using the CFX solve manager,
alternatively, CFX can be configured to automatically monitor each run, or export the convergence

history to CSV files which can be read by CAESES as results tables for each run.

10
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Parameterize the Input File Sduct.cse

In this step we will edit the ANSYS® CFD-Post post process input file,

Sduct.cse by creating controls.

» Open Sduct.cse

» Find the working directory (“RESULTPATH") and replace all with the “ResultsPath” entry.
Overview |cfxrun.sh X | Sduct.pre X  Sduct.rpl X | Sduct.cd %

# Template Name | Sduct.cse

28
29
30
31
32
33
34
35
36
37
38
39
40

END B
> load filename=<entry>Resultpath</entry>\
Sduct_00l.res, force reload=true

VIEW:View 1

Camsra Mode = User Specified
CAMERA:

Option = Piwot Point and Quaternion

Pivot Peint = 0, 1.375, 5

Scale = 0.228391

Pan = 0, 0

Rotation Quaternmion = 0.279%848, -0.364705, -0.115917, 0.880476
END

11
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Setting up the Computation

For postprocessing, we need to have results files and values, which will

be inserted in the Results Files and Results Values window of the software

connector. In order to get these, we have to trigger a first run - either with CAESES®, or

externally. Since we have already changed parts of the input files in the previous steps, we want

to use CAESES® to run ANSYS® CFX®. Therefore we have to set up the computation “Runner”:

»  Click on “Runner” in the center of the software connector. i
» In the object editor of the selected object “Runner”, activate Q Runner
“Remove existing Result Files”. This makes sure that with ;
each run the previous simulation files get deleted
automatically, and is similar to the & = 4 » Runner Qa0 x
“Allclean” command.
Runner >
» Create a new “Local Application” by ; )
Execution Settings
clicking on the plus-button next to the ¢ o @ config @
attribute, and call it “CFXRUN". Ao 1@
> As executable write “cfxrun.sh”. This will giiﬁsrce Manager (eaicaisetup 17 + @@
trigger the “cfxrun.sh” script. o+ -
» Run the computation by clicking on the Fonstrants Drop here to append @
green run button (’) Asynchronous % =
Update 2
»  While the computation is running, you -
e s g
. . esu =
can check the output in the Task Monitor.
Local Execution Settings
When the computation is done, check the  oc@ Application [ L3 CRYXRUN 2+ @@
results on your hard disc, to see how the  OWtPutFi= o @)
results are handled by CAESES®: A new folder & CEXRUN W0 x
was created, with the name of the current
£3 [ CFXRUN
project file (*.fdb). In this folder all results can
General
be found. Executable cfxrun.sh myE)]
Stored in Project  [] @
Stored in User % @

12

Config

Application Execution Settings

Maximum Number
of Running
Instances

1

Enable Advanced

Settings |
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Result Values Part 1

In order to assess the simulation, we need to have result files which
provide for example the pressure drop. These values can be extracted

from any text files.

» Inyour file explorer, go to the baseline directory which was created during the last run and
check for the “values.txt” file.

» Add the “values.txt” file to the Results Values window of the software connector by using
either drag & drop, or by using the green plus button at the window.

» Double-click on “values.txt” in the software connector to see the content.

+ : @ Result Files Q e Result Values @ 4=

/o

AENE Reper.

AENE Loges fey

D TS

values.txt

13
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Result Values Part 2

After importing the template result file. We are now able to extract result

values such as the pressure drop.

Add a value by clicking on the plus button and name it “dP”.

In Anchor String part add “Table 5.” where CAESES® will be searching from this point on.
Set line to “1” (in this case, this means: always the last row of the file).

Set column to “0”.

Now create a parameter for the value by clicking on the blue parameter symbol in the
results preview table. This parameter will be the objective of the simulation at a later stage.
Select the evaluation parameters, and create a scope. Set the name of this scope to

“CFX_evaluation” (note, names can be user-defined i.e. arbitrary).

[E]' -D Q CFXConnector X | [ FileViewer X [FHMEEUEE]
Overview |cfxrun.sh X

General File
Template Na | values.txt Buoyancy Model Non Buoyant *
Domain Motion Stationary
Subfolder Reference Pressure 1.0000e+00 [atm]
Heat Transfer Model Isothermal
Column Separator Fluid Temperature  2.5000e+01 [C]
Turbulence Model k epsilen
Find number @ Turbulent Wall Functions Scalable
Custom
Values o Tablt.& 4. Bou.nd;ry Physics for sduct 001
Domain Boundaries
Name Q dp B + Default Domain Boundary - inlet
Type INLET
Type FDouble - Locatl:ion INLET
Settings
Line 1 e:: Flow Regime Subsonic
Mass And Momentum Normal Speed
Column 0 _: Normal Speed 1.0000e+00 [m s~-1]
Turbulence Medium Intensity and Eddy Viscosity Ratio
Anchor Strin | Table 5. a Boundary - outlet
Type OUTLET
Occurrence | First - LDCEFiDn OUTLET
Settings
Average D Flow Regime Subsonic .
Mass And Momentum Average Statlic Pressure
N Pressure Profile Blend 5.0000e-02
ResulizRioview Relative Pressure 0.0000e+00 [Pal
Value Type Pressure Averaging Average Over Whole outlet
Boundary - w_sduct
dP 0.1331 FDouble [x] Type WALL
Location WALL
Settings
Mass And Momentum No Slip Wall

Wall Roughness Smooth Wall

4. User Data

Table 5.
1. jl [Pa]

v

a strong oscillating result, you might average the values over a specific time.

Remember that this parameter is the result value of the last iteration or time step. If you have

14
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Result Files

In the Result Files window of the connector, output files from the CFD

calculation are referenced. Typical output files are pictures, tables, text

files and CFD solutions.

» Add the “Sduct.res.case” Ensight file to this window, either by using drag & drop, or by

using the plus button in the corner.

+ @ @ Result Files Q e Result Values @ %

ARSNS epors

ARESNS Loge: &
Late Loz

15
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Running the Case

Now the software connection is completed, and a first test case can be

started.
Set the parameter R=4 ) Q0 x
Maximum_Number_of Iterations to “1000”.
. fi
You can also decrease the “Residual_Target” &) config |
. s . General

factor, which will increase the computational
. config
time. —

A Di " opt/ans .‘
Go back to the software connector and run the revsR ys_inc/vl| @
simulation (again by using the P> button). PN SN C:fUsers/TEMP/Deskt -,

‘ getResultsDir() ©
1e05s  |-|[?)
4 @

Residual_Target

Number_of_Processors

16

Outlet_Relative_Pressure

Inlet_velocity
number_of_Blayers

Blayer_height

Maximum_Number_of_Iterations( 1000 . ©
—

b @
L @
L [H@
o1 [-[(2)
@)
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Appendix

This appendix will guide you through the process of creating your own ANSYS script files.

17
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Meshing with ANSYS® ICEM CFD® Part 1

A1

In this section, a script file is created using ANSYS® ICEM CFD® to

automate basic unstructured meshing of the flow domain.

»  Open ANSYS® ICEM CFD®:
»  Begin recording scripts by selecting “File > Replay Scripts > Replay Control”. Ensure that

recording scripts is checked

File | Edit View Info  Setings Help

Mew Project...
) N W | Geometry ]Mes Operations in script
Cipen Project.
Save Project %G +¢f ‘\( ‘ '
Save Project As.. _———
Clase Project..
Change Warking Dir.
Geomeiry -
Mesh -
Blocking P
Aftributes -
Parameters -
Caresian -
(]
Import Mactel W Record (after current) 1 All commands
Irport Geornetr %
: P et 4 “ Do one | Do al | Do range Skip
mport Mes -
Export Geometry Load Save Edit Insert
-
Export Mesh P Delete one Delete all Delete range Renumber
I Always update  _| Ighore errars Stop Clean

I
Exit Loau¥script file ﬂl
Run from script file

| Recording scripts

»  Change the working directory of ICEM to the working directory by selecting “File > Change
Working Dir...”
» Import the geometry file by following the path “File > Geometry > Open Geometry” and

selecting Sduct.tin as the import file.

o
r--
[

2l

b a1 |
0 o M Lt

18
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Meshing with ANSYS® ICEM CFD® Part 2

In this step we are going to continue to create the meshing macro.

Under Geometry tab, pick Repair Geometry and click OK in the

openi

ng menu.

Under the mesh tab, bring up the part mesh-setup dialogue,

and input size parameters for all surfaces imported using the

values indicated. Leave all other parameters as zero.

File Edt View Info  Seftrgs Help

=8 AAE oo o

Wesh | Blockng | Ede Mesn | Output Mesh

EogsR ae Rt

When the mesh is finished, inspect the

prism mesh and split the elements if

el

& Gacmairy Part Mesh Setup
:j‘ g::";“ Pat - | Prism | Hesarcore | Mesmum sice | Height | Height rafio | Mun laers | Teta sice ratio | 1
& curves BREFCOLOR r | | | ]

Lar sutacas INLET (1) i ] 0 ]
i"a_P::&hp o OUTLET wos | o |0 a | ] ‘
| IMLET o HALL r 003 ] ] ) T

W Show size parans using scale factr

1 Apply Infiafion paramesers ¥ curves

i Remave infssion parameters #om curves

Highilghtad parts have o keast one: blank feidt because not a1 snities 0 hal part have Iderdcal paramstars

Create an unstructured volume

mesh

Mesh

Volume Mesh tab.
Create a boundary layer under

the Prism Mesh tab.

desired.

File Edt View Info Setings Help

eAAE
Loyol 2]
L’;lil Model

sl Geometry
|0 subsets

Geomety | Mesh | Bloc

Eas 3

L2Es Y

e

v;-dm-w ?

I o

W Inherit Part

RonN
Ef‘ﬂ-ﬁﬁ

-~ Build Topology.

‘ Tolerance (3005
Flter by angle

——————

i Fittr points

|| 2 Fter curves
|

| Buikd Topo

‘ Method [l pars P E| ‘
¥

E ooy [J o< | pismis

E @ EEE o x| ceomery Mesh ey

BORAKR Qe Bihen,

| £t Mesn | Qutput Mesn

by bringing up the Compute
S hepcoLon

dialogue box under the

[ unéefined
ungedned

(]
[ unéefined
(]

have idenlical parameters

it parts have a1 least ana biank field bac:

anentie] |
3

I enties in that part

noply | D]

Prism Mesh

Select Mesh [From Fie

= ‘
Select Parts for Prism Layer e

- Fre inflaion (Fluant Meshing)
+ Post Inlation (CEM CFD Prism)

B Load mesh afer conpletion

conpute] [_on | romss

19

INLET: 1
CUTLET 1
WALL: 4
Using defaut tapo folerance
Using Beault tapo foleranca

ar parame

Firished seting par parameters
Firihid $efing pan pirameters
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Meshing with ANSYS® ICEM CFD® Part 3

In this step we are going to continue to create the meshing macro.

Click through the “Settings > Solver menu” to bring up the solver setup dialogue and
specify ANSYS® CFX® as the solver type.

Click on the output tab and select write input to write the mesh files, save the project when
prompted to the working directory.

Ensure that the .boco file is also saved in the working directory, and then export the files.

In the replay control window, select “Done” and save the replay in the working directory as
“Sduct.rpl”.

Close ANSYS® ICEM CFD®.

Replay Control ) (A (%

Operations in script

191, ic_csystem_set_current global

182, ic_hoco_nastran_csystem reset

193, ic_uns_update_family_type visible {BREPCOLOR WALL INLET QOUTLET ORFM CREATED_MATERIAL_G} {INODE
184, ic_undo_group_end

195. ic_uns_set_modified 0

196, ic_uns_update_family_type visible {BREPCOLOR WALL INLET OUTLET ORFM CREATED_MATERIAL_G} {INODE
197, ic_delete_empty_pans

195, ic_undao_group_end

199, ic_uns_metric visible Guality

200. ic_uns_subset_configure {stuck elements} -shade flat_wire -colar_by_guality 1

201, ic_uns_subset_configure &ll -shade flat_wire -color_by_guality 1

202Z. ic_uns_subset_configure Selected -shade flat_wire -color_by_guality 1

204, ic_uns_subset_configure {stuck elements} -shade wire -color_by_guality 0

204, ic_uns_subset_configure &ll -shade wire -color_by_guality 0

W Record (after current) 1 All commands
Do one | Do all | Do range | Skip |
Load | Csae) | Edit | Insert |
Delete ane | Delete all | Delete range | Renumber |
I Always update | lgnore errors Stop | Clean |

Done |

\/ Group parts by giving them identical spacing, which later you can easily find by searching for

the spacing value and link to a common entry in the software connector
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Set up the CFX Case file Part 1

In this step we will create a template simulation setup and a script file

using CFXpre to automatically generate a simulation setup and export

the solver definition file.

» Open CFX and create a new project, importing the mesh generated in the previous section.
» Set up the simulation case as desired or as is necessary. Some basic sample boundary
conditions are:
Boundary Name \ Boundary Type \ Details
inlet \ Inlet \ Normal velocity: 1.0 m/s
outlet \ Outlet \ Zero average gauge pressure
wall \ Wall | No slip - Rotating
» Ensure to set up an execution control object, this will be important for defining the solver
working directory.
Fle Edit Session Insert Tools Help
» Export the case setup from the menu by | juce TR (=S I £
S Open Case ctri+o
browsing through File > Export > CCL, naming lss R
= save case Ctrl+S
the file “Sduct.ccl”, and ensuring to select “save |E seve casess
) ) 5P Reload Mesh Fles
all objects” to export the entire setup. - .
. g
» Close the project Sevepictre..  cilan ;'
Recent Case files v
Recent CCL Files v
Recent Session Fles >
Quit ctri+Q
Export CCL * x
Look in =] -0 O 0 @G ve All Objects
& compueer [ Hame O | S -
E Docume. @ ANALYSIS TYPE
E Sal=) Daf::;\;l}mnam

Ale name:  ([Sducq s ) &
& Water Ideal Gas -
Files of type: [CCL Files (* ccl) =]  cancel Ll »

outlet

&' SOLUTION UNITS
ﬁ SOLVER CONTROL
1 QUTPUT CONTROL
COORDINATE FRAMES
TRANSFORMATIONS
B (&) MATERIAL:
& Air ideal Gas
& Aratasc
& Aluminium

& Copper
& soot
& st

Waf
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B CAESES

Set up the CFX Case file Part 2

Follow up of the step before.

» Create a new session file, naming it Sduct.pre and save it to the working directory, then

select “Start Recording”.

Fle Edit | Session Insert Tools Help

J_| = [% Play Session. ..
%o Play Tutorial...

Session Insert Tools

[ - Play Session. ..

Play Tutorial. ..

New Session...

=
ao
A
B
ao
8]
oo
0
an

Import the mesh file Sduct.cfx5.
Import the Sduct.ccl file created.

Write a solver input file to the working directory.

vVvyyvyy

Stop recording and close CFX, saving the project if desired.
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B CAESES

Set up Basic Post Processing and Results Part 1

Finally, a script file is created to automate post processing in CFX Post,
and integrated into CAESES to automate the post processor execution.

Results are imported into CAESES for post processing and optimization.

» Open CFXpost and start a new session, saving it to the working directory, and naming the
script file “Sduct.cse”.

»  Start the recording.

» Create a table in CFX post to compute the pressure difference between the inlet and outlet
boundaries, and then export it as a txt file in the working directory.

» Create a new table in the report section of the CFX Post object tree by right-clicking on

report heading, and selecting “Insert > Table”.

|_:_| User Locations and Plots
[F Default Transform

- E? Default Legend View 1
; % Streamline 1

- W] ) Wireframe

- Mg File Report Report Templates. .. E“ Cha
: ﬁ ::;:icn:;:;to Load 'Generic Report' Template Comment
- [ed> Selution Repe Refresh Preview _ Rgure

. User Data )
1 [ nieelser Drnnnﬁ:n:g Publish

o IO T e WO |

Details of Report Edit

Appearance I
Edit in Cernmand Editor

—Raures

» In the first cell, enter the following equation:

“=massFlowAve(Total Pressure)@inlet -massFlowAve(Total Pressure)@outlet”.

Table 1
Al = massFlowAve(Total Pressurel@inlet -massFlowAve(Total Pressure)@outlet
A B C D E
1
2
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BCAESES

Set up Basic Post Processing and Results Part 2

A7

Follow up of the post processing and results set up.

Uncheck all items in the report subheading except the table created in the previous step,
then right click on report and select publish.
Select “Text” as the Export format, and then export the file to the working directory.

Stop recording.

Fle Edit Session Insert Tools Help
Eféﬂ#@j &y @Locationv ¢§E§§§ ;ﬁ‘_@giﬁq¢® x@]ﬁ.
Qutline l Wariables ] Expressions ] Calculators ] Turbo]
= @ Cases
| @) Sduct_o01
- (3 Default Domain
OPE inlet
OPE outlet
MIPE w_sduct
+ @ Mesh Regions
- | User Locations and Plots
&q Default Transform
E? Default Legend View 1
@ Plane 1
Dﬁ Streamline 1
O wireframe

= Report
[ &g> Title Page Publish Report X
+- [] &> Ffle Report
+- []gd» Mesh Report Format -
+- []g§> Physics Report
5 [ Solution Repo File biects/06_Sduct/Report.txt @
[1[A] User Data 1 ¥ Save images in separate folder

[ Generate CFD¥iewer Fles (CVF) for Fgures -

More Options...

oK | Cancel |

+ Display Properties Defaults
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